Converting CLAN (.cha) files into MSWord documents

Open up a CLAN transcript. CLAN filenames have a .cha extension.

As a safeguard, use the ‘Save-As’ command in CLAN (which is under the ‘File’ menu), and
save a copy of the CLAN transcript somewhere else, say on your desktop. Later, you can
delete this copy, after you’ve messed with it.
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In the copy of the transcript, press ESCAPE-A to expand all bullets (time markers). This
command is also under the ‘Mode’ menu.
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Under the ‘Edit’ menu, choose ‘Replace and Find Next’.

In the dialogue box, click on the ‘insert bullet’ button. This will insert the ‘bullet’ symbol
into the ‘Find’ field; however, you will only see a space in the ‘Find’ field when you do this.
(The bullet will only be visible as a space before the cursor in the ‘Find’ field.)
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6. Leave the ‘with’ field blank.
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7. Click on the ‘replace’ button.

8. Type a ‘!” (shift-1). (Notice that this is one of the options you see at the bottom of the CLAN
transcript after you do step (7). It looks like this:)

dago:s cat *%snd:"Alfred_Keye August 08" 199552 200684+
dago:s cat *%snd:"Alfred_Keye_August 08" 203307 204387+
dagu:s cat (the preferred way of saying this word) «%snd:"Alfred_Keye August 06" 214034 215015
dagu:s cat (the preferred way of saying this word) «%snd:"Alfred_Keye August 06" 217498 218560
e:hé’ yes *%snd:"Alfred_Keye August 08" 224638 225741+
e:hé” yes «%snd:"Alfred Keye August 06" 227982 228939«

! - REPLACE ALL; <space> - JUST THIS ONE; n - DO NOT REPLACE; G - ABORT

L

The result is that all bullets (¢) will be replaced by ‘nothing’; (in other words, they will be
deleted).

Congratulations: you’ve just deleted all those pesky bullets, and this is the only way to do it
easily! Here is an example of a CLAN transcript with all of the bullets deleted.

e o6 Carrie Vll:Users:cdyck:Desktop:Alfred_Aug_06.cha
oyan’eda’ the chief's clanmother %snd:"Alfred_Keye August 06" 1286454 1288393
aga:t¢:de’ | heard it %snd:"Alfred_Keye August 06" 1297564 1299567
aga:tg:de’ | heard it %snd:"Alfred_Keye August 06" 1301676_1303726
ehsna’jo:de’ you will boil something %snd:"Alfred_Keye August 06" 1310044 1312285
ehsna’jo:de” you will boil something %snd:"Alfred_Keye_ August 06" 1315931_1317305
degr¢’ eight %snd:"Alfred_Keye August 06" 1325910_1326717
degr¢’ eight %snd:"Alfred_Keye August 06" 1330598 1331585
agi’ | said %snd:"Alfred_Keye August 06" 1336846_1338227
agi” | said %snd:"Alfred_Keye August 08" 1340160 1341344
ganagaédahkwa’ a whistle %snd:"Alfred_Keye August 06" 1349533 1351367
ganagaédahkwa’ a whistle %snd:"Alfred_Keye August 06" 1355376_1357484
ganohsa:k’ah beside the house %snd:"Alfred_Keye August 08" 1363718 1365848
ganohsa:k’ah beside the house %snd:"Alfred_Keye August 08" 1368350_1370237
onghsatgi:s’ah an ugly house %snd:"Alfred_Keye August 08" 1377828 1380185
onghsatgi:s’ah an ugly house %snd:"Alfred_Keye August 06" 1382131_1384233
gwenihsd:"oh change, money %snd:"Alfred_Keye_ August 06" 1395618 1397690
gwenihsd:'oh change, money %snd:"Alfred_Keye August 06" 1401440 1404587
kné:ha™ my mother %snd:"Alfred_Keye August 06" 1411999 1413775
knoé:ha™ my mother %snd:"Alfred_Keye August 06" 1415498 1416497
hahé:ha’ he sets it up on top of something %snd:"Alfred_Keye August 06" 1422947 1424108
ga:ye’ itis lying there %snd:"Alfred_Keye August 068" 1431747_1433529
ga:ye’ itis lying there %snd:"Alfred_Keye August 06" 1434726 1436334
sa:weh itis yours %snd:"Alfred_Keye August 06" 1444600 1445849
s&:weh itis yours %snd:"Alfred_Keye August 06" 1447942 1449683
do:gd” | don't know %snd:"Alfred_Keye August 06" 1456565 1457883
do:gd” | don't know %snd:"Alfred_Keye August 06" 1460617 1462010
do: ii7 let me do it! %snd:"Alfred_Keye August 06" 1468775_1469988
do: ii7 let me do it! %snd:"Alfred_Keye August 06" 1472627 1473852
sada:tehs géh? are you thirsty? %snd:"Alfred_Keye August 06" 1486697 1488282
sadéa:tehs géh? are you thirsty? %snd:"Alfred_Keye August 06" 1491169 1492870
gae nh¢: dihséhdegyQ:? where do you come from? %snd:"Alfred_Keye August 06" 1500505_1504313
gae nh¢: dihséhdegyQ:? where do you come from? %snd:"Alfred_Keye August 06" 15065385 1509457
de’ho’dé” sya:sgh? what is your name? %snd:"Alfred_Keye August 06" 1516963 1519413
de’ho’dé¢” sya:sgh? what is your name? %snd:"Alfred_Keye August 06" 1522852 1525238
de’ho’dé’ ghsnegehd’™ what will you drink? %snd:"Alfred_Keye August 06" 1533094 1535491
de’ho’dé¢’ ehsnegeha™ what will you drink? %snd:"Alfred_Keye August 06" 1539133 1542529 A
@End

210906[E][CHAT] * 234
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9. Next, under the ‘Edit’ menu, choose ‘Select All’ in order to select all the text in the CLAN
transcript. Then choose ‘copy’ to copy all the text into the cut/copy-and-paste buffer.

10. Open a blank MSWord document.

11. Under the ‘Edit’ menu in MSWord, choose “Paste”. This will paste all the text from the
CLAN transcript into the MSWord document.

12. Under the ‘File’ menu in MSWord, choose “Save” and save your new document. MSWord
wrecks documents on a regular basis, so you will want to save frequently, and make a back-
up copy every once in a while.

13. Under the ‘Edit’ menu in MSWord, choose “Select All” and then change the font in the
entire document to Gentium or Doulos SIL. This will make sure that all your unicode
characters are displayed correctly (if you used a unicode keyboard).

14. You can now close CLAN and delete the file or copy that you created in step (2).

15. Now that you have created an MSWord document, you probably want to get rid of all the
“junk” that was useful in CLAN, but not pretty in an MSWord document. First of all, delete
any headers at the beginning of the MSWord document, and the ‘@End’ footer at the end of
the document. (CLAN headers and footers all begin with the @ symbol). Or else, transform
the information in the headers into an introductory paragraph.

@Begin

@Language: cay

@Participants: MH Marge Henry Speaker, K Kehte Transcriber, skip Skip This

@Dependent: transl, transl2

@Transcriber: Roronhiakehte Deer

@Date: July 4, 2004

@Location: Woodland Cultural Centre Meseum

@Situation: A man is talking in the background and there are a couple of
people milling about and opening and closing doors. Hayendaje
Longboat is also present. Carrie Dyck joins towards the end.

@Warning: The beginning male voice is not a fluent speaker and the utterance
may not be correct Cayuga. As well, this document was transcribed by
the same person and may contain errors.

@Comments: The Cayuga in this transcription was written using words as
they are acceptedly written (for the most part), not necessarily how &
they were said. To hear this speaker's particular dialect and
pronunciation, refer to the sound file. English punctuation was also
used, and these indicators (for example, a period to mean the end
of a senctence) should be taken as approximate. Any difference
in dialect between use of dy and gy was noted. Any occurrence of non-
dialogue sounds (such as 'hems' and 'haws'), as well as
explanantions, are in square brackets.

To carry out the next steps, you’ll want to know what the CLAN ‘junk’ is. First, click on the
‘show/hide §‘ button, which is on the ‘Standard’ toolbar. (To see the ‘Standard’ toolbar, choose it
from the ‘Toolbars’ menu, which is under the ‘View’” menu.) Clicking on the ‘show/hide
button reveals special characters like the tab and the return characters.
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Look at the MSWord version of the CLAN transcript, and you will see lines beginning like this:

Y%transl:—

&am [=! clears throat] Ne7 ni:7 ahi:” ega:tro:wi?, ng:gyéha

gkniho:wi{”,O0%snd:"M_Henry_July_4_05"_24058_301830
%transl: —+ ThatIthink I'will speak of this. Iwill tell you both«
%transl2: - & Asfor me, I think I'will speak of this: I-will tell you both

%transl: 1s an example of a CLAN tier name. The arrow represents a tab marker.

Next, look at the MSWord version of the CLAN transcript, and you will see lines ending like
this:

9osnd:”M_Henry_July_4_05"_24058_30183

L“H-J TITL u\..) Y- 5\‘10 IItd u&] ub} e 700114 IV 1 lblll) q,ux) — X VI _TIJJJ7_TTIUULVU
%transl: - Many different things we used to do<
%transl2: -+ We used to do many different things.«

[&a:] a’akiyenawd’s ne’ kso:t.%snd:"M_Henry_July_4_05"_48820_52026
%transl: - we helped our grandma= A
%transl2: - We helpedour grandma.

AV a7 al7 cnccamelle naclan 70t d. NG ¥Yaumens Yao) 4 nrll rannrs ranne o

%snd: is a CLAN command, which tells the CLAN program to look for part of an audio file.
“M_Henry_July_4_05" is an example of a file name (an audio file).

_24058_30183 is an example of a time code; this part tells the CLAN program which part of the
audio file to play: in this case, the section from 24058 milliseconds to 30183 milliseconds.

For later reference, I will refer to sections of this CLAN command as follows; the bolded parts
are just generic names: “filename” stands for a file name like “M_Henry_July_4_05"; etc.

%snd:”’filename”_startnumber_endnumber

You will want to have an easy way to delete all this now-useless information quickly, and the
‘Replace’ command in MSWord can do this for you.

16. In MSWord, under the ‘Edit’ menu, choose ‘Replace’. Then perform the ‘find and replace’
operations shown below.
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17. Once you see the ‘Find and Replace’ menu, click on the ‘down arrow’ button to see more
options.

e OO0 Find and Replace

Find | Replace | Co To )

Find what: v
Options: Search Down

Replace with: =

@ Replace Al Replace ) ( Cancel ) ( Find Next

In the ‘find what’ field, type %trans: (this is an example of a CLAN tier name; substitute
whatever name is in your transcript.) Then from the ‘special’ pull-down menu, choose ‘tab
character’. Notice that the ‘find what’ field now say %trans:/t ("t is the special code for
finding a tab character in MSWord.)

Leave the ‘Replace’ field blank. Then click the ‘Replace All’ button. This command will
erase all the %trans: CLAN tier names, and also the tab that follows them.

enon Find and Replace

Find | Replace | GoTo

Find what: %transl:Ad
Options: Search Down

Replace with:

@ 1 Replace All ) ( Replace . ' Cancel ) (Find Next)
L3

Current Document Down & !

Search

] Match case
"] Use wildcards

__!| Sounds like
! Find all word forms

Find

i Format |5) [ special [3)
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18. Repeat step (17) to get rid of any CLAN tier names. Just type in the appropriate tier name in
the ‘Replace’ field.

19. Now you’ll want to get rid of the CLAN commands which tell the CLAN program to look
for part of an audio file. First, under the ‘Edit’ menu in MSWord, choose ‘Replace’. Once
you see the ‘Find and Replace’ menu, click on the ‘down arrow’ button to see more options.
In the ‘find what’ field, type the following complicated command:

don’t change these underscores

/A

%snd:”filename”_startnumber_endnumber.

don’t change

the Yosnd.: part between the quote marks “”, instead of
“filename”, type the name of the audio file;

for example “M_Henry_July_4_05"

Remember that ‘startnumber’ and ‘endnumber’ stand for numbers. You want to replace, for
example, every 5-digit number with ‘nothing’ (in other words, you want to delete all the 5-digit
numbers). You will also want to delete all 6-, 7-, 8-, 9-digit, and higher numbers.

To replace any 5-digit number, under the ‘Special’ menu in the ‘find and replace’ dialogue box,
choose ‘any digit’. The symbols A# will show up in the ‘find’ field. (*# stands for ‘any digit’ in
the find command.) Do this five times. To replace a 9-digit number, do this 9 times. (Etc.)

In the end, the ‘find what’ field in the ‘find and replace’ dialogue box should look something like
this:

%snd:"M_Henry_July_4_057_MMNNENENE_NENENENENE

Leave the ‘replace with’ field blank. Then click on the ‘replace all’ button.

This command will erase all references to the file “M_Henry_July_4_05", and will replace all 5-
digit ‘startnumber’ and ‘endnumber’ designations.
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Next, you’ll want to do another find and replace command:

%snd:"M_Henry_July_4_057_MNMNNENENE_NENENENENENE

Pl t

any 5-digit any 6-digit
number number

And then: / \

%osnd:"M_Henry_July_4_057_MNMNNENENENE_NENENENENENE

The ‘Find and Replace’ dialogue box will look something like this in the end. (In this picture,
some of the command at the end of the ‘Find what’ field doesn’t show up because the text of the
command is longer than the find field. But it’s there!)

e OO Find and Replace

. Find | Replace | GoTo )

Find what: %snd:"M_Henry_July_4_05"_ASAZARAZAE _AJARARA

Options: Search Down

Replace with:
(«) ( Replace All ) ( Replace ) ( Cancel ) (FindNext)
Search k

Current Document Down 5

| Match case

| Use wildcards
__| Sounds like
! Find all word forms

Find

No Formatting Format | :’ Special | C!

And you’ll want to do this until you’ve erased all file references, adding A# to the ‘startnumber’
and ‘endnumber’ references as appropriate.

By now, you will have erased most of the CLAN junk. You can do the rest by hand!



